Определить родителей элемента иерархического справочника

Случается, что в для элемента справочника с большим уровнем вложенности необходимо определить родителя уровня три, к примеру. Ниже код для справочника «Номенклатура», однако он подходит для любого иерархического справочника:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
Функция НайтиТретийУровеньВложенностиНоменклатуры(Номенклатура) Экспорт
 
	Уровень3 = Номенклатура.Родитель;
	Уровень2 = Уровень3.Родитель;
	Уровень1 = Уровень2.Родитель;
 
	Если Уровень1 <> Справочники.Номенклатура.ПустаяСсылка() Тогда
 
		Пока Уровень1.Родитель <> Справочники.Номенклатура.ПустаяСсылка() Цикл
			Уровень3 = Уровень3.Родитель;
			Уровень2 = Уровень2.Родитель;
			Уровень1 = Уровень1.Родитель;
		КонецЦикла;
 
		Возврат Строка(Уровень3);
	Иначе
		Возврат "";
	КонецЕсли;
 
КонецФункции // НайтиТретийУровеньВложенностиНоменклатуры()

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Можно использовать следующие HTML-теги и атрибуты: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

WP-SpamFree by Pole Position Marketing