Объединение таблиц значений

Для того, чтобы добавить значения одной таблицы значений к другой, используем следующий код:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
// ТаблицаПриемник - таблица, к которой добавляются значения.
// ТаблицаИсточник - таблица, из которой добавляются значения в таблицу-приёмник.
//Сформируем массив совпадающих колонок.
МассивСовпадающихКолонок = Новый Массив();
Для Каждого Колонка ИЗ ТаблицаПриемник.Колонки Цикл
 
	Если ТаблицаИсточник.Колонки.Найти(Колонка.Имя) <> Неопределено Тогда
 
		МассивСовпадающихКолонок.Добавить(Колонка.Имя);
 
	КонецЕсли;
 
КонецЦикла;
 
Для Каждого СтрокаТаблицыИсточника ИЗ ТаблицаИсточник Цикл
 
	СтрокаТаблицыПриемника = ТаблицаПриемник.Добавить();
 
	// Заполним значения в совпадающих колонках.
	Для каждого ЭлементМассива Из МассивСовпадающихКолонок Цикл
 
		СтрокаТаблицыПриемника[ЭлементМассива] = СтрокаТаблицыИсточника[ЭлементМассива];
 
	КонецЦикла;
 
КонецЦикла;

В результате к таблице-приёмнику снизу поочерёдно добавляются все строки из таблицы-источника.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Можно использовать следующие HTML-теги и атрибуты: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

WP-SpamFree by Pole Position Marketing