Архив рубрики: Общие вопросы разработки

Определить родителей элемента иерархического справочника

Случается, что в для элемента справочника с большим уровнем вложенности необходимо определить родителя уровня три, к примеру. Ниже код для справочника «Номенклатура», однако он подходит для любого иерархического справочника:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
Функция НайтиТретийУровеньВложенностиНоменклатуры(Номенклатура) Экспорт
 
	Уровень3 = Номенклатура.Родитель;
	Уровень2 = Уровень3.Родитель;
	Уровень1 = Уровень2.Родитель;
 
	Если Уровень1 <> Справочники.Номенклатура.ПустаяСсылка() Тогда
 
		Пока Уровень1.Родитель <> Справочники.Номенклатура.ПустаяСсылка() Цикл
			Уровень3 = Уровень3.Родитель;
			Уровень2 = Уровень2.Родитель;
			Уровень1 = Уровень1.Родитель;
		КонецЦикла;
 
		Возврат Строка(Уровень3);
	Иначе
		Возврат "";
	КонецЕсли;
 
КонецФункции // НайтиТретийУровеньВложенностиНоменклатуры()

Программирование в 1С за 21 день. Лекция 21

Выкладываем ссылку на страницу двадцать первой лекции курса «Программирование в 1С за 21 день«. На странице вы найдёте сами лекции, домашнее задание, решение домашнего задания и базу с примерами.

На лекции будет изучено:

  • Воронка продаж;
  • Бизнес-процессы.

Весь материал по лекции можно скачать одним архивом.

Программирование в 1С за 21 день. Лекция 20

Выкладываем ссылку на страницу двадцатой лекции курса «Программирование в 1С за 21 день«. На странице вы найдёте сами лекции, домашнее задание, решение домашнего задания и базу с примерами.

На лекции будет изучено:

  • Основы CRM-систем.

Весь материал по лекции можно скачать одним архивом.

Программирование в 1С за 21 день. Лекция 19

Выкладываем ссылку на страницу девятнадцатой лекции курса «Программирование в 1С за 21 день«. На странице вы найдёте сами лекции, домашнее задание, решение домашнего задания и базу с примерами.

На лекции будет изучено:

  • Универсальность механизма расчёта заработной платы в системе;
  • Диаграмма Ганта.

Весь материал по лекции можно скачать одним архивом.

Программирование в 1С за 21 день. Лекция 18

Выкладываем ссылку на страницу восемнадцатой лекции курса «Программирование в 1С за 21 день«. На странице вы найдёте сами лекции, домашнее задание, решение домашнего задания и базу с примерами.

На лекции будет изучено:

  • Технологии расчёта заработной платы в системе в зависимости от условий.

Весь материал по лекции можно скачать одним архивом.